[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GLSA: php



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - --------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200211-005
- - --------------------------------------------------------------------

PACKAGE : php & mod_php
SUMMARY : buffer overflow
DATE    : 2002-11-20 13:11 UTC
EXPLOIT : local & remote

- - --------------------------------------------------------------------

- From advisory:

Two vulnerabilities exists in mail() PHP function. The first one 
allows to execute any program/script bypassing safe_mode restriction, 
the second one may give an open-relay script if mail() function is not 
carefully used in PHP scripts.

Read the full advisory at
http://marc.theaimsgroup.com/?l=bugtraq&m=103011916928204&w=2

SOLUTION

It is recommended that all Gentoo Linux users who are running
dev-php/php-4.2.2-r1 and/or dev-php/mod_php-4.2.2-r1 and earlier 
update their systems as follows:

emerge rsync
emerge php
  and/or
emerge mod_php
emerge clean

- - --------------------------------------------------------------------
aliz@xxxxxxxxxx - GnuPG key is available at www.gentoo.org/~aliz
rphillips@xxxxxxxxxx
- - --------------------------------------------------------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE924srfT7nyhUpoZMRAj4XAJ9YugJ+Gvb0+dQbmUJIFPbJJMFEgACgtPNQ
OXAlpSYMVp0CcExWEK2ZQlI=
=kuEw
-----END PGP SIGNATURE-----