[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ GLSA 200802-04 ] Gallery: Multiple vulnerabilities



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200802-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Gallery: Multiple vulnerabilities
      Date: February 11, 2008
      Bugs: #203217
        ID: 200802-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were discovered in Gallery.

Background
==========

Gallery is a web-based application for creating and viewing photo
albums.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  www-apps/gallery       < 2.2.4                           >= 2.2.4
                                                                 < 2.0

Description
===========

The Gallery developement team reported and fixed critical
vulnerabilities during an internal audit (CVE-2007-6685, CVE-2007-6686,
CVE-2007-6687, CVE-2007-6688, CVE-2007-6689, CVE-2007-6690,
CVE-2007-6691, CVE-2007-6692, CVE-2007-6693).

Impact
======

A remote attacker could exploit these vulnerabilities to execute
arbitrary code, conduct Cross-Site Scripting and Cross-Site Request
Forgery attacks, or disclose sensitive informations.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gallery users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/gallery-2.2.4"

References
==========

  [ 1 ] CVE-2007-6685
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6685
  [ 2 ] CVE-2007-6686
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6686
  [ 3 ] CVE-2007-6687
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6687
  [ 4 ] CVE-2007-6688
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6688
  [ 5 ] CVE-2007-6689
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6689
  [ 6 ] CVE-2007-6690
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6690
  [ 7 ] CVE-2007-6691
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6691
  [ 8 ] CVE-2007-6692
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6692
  [ 9 ] CVE-2007-6693
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6693

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200802-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHsNVUuhJ+ozIKI5gRAlQUAJ9lFeYFWn1P5j9gCoQZeMPDd2Qv7gCeMHGd
9O6IeInam6ViQoXcHvw1twU=
=Gzzi
-----END PGP SIGNATURE-----