[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ GLSA 200802-05 ] Gnumeric: User-assisted execution of arbitrary code



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200802-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Gnumeric: User-assisted execution of arbitrary code
      Date: February 12, 2008
      Bugs: #208356
        ID: 200802-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Several integer overflow vulnerabilities have been reported in
Gnumeric, possibly resulting in user-assisted execution of arbitrary
code.

Background
==========

The Gnumeric spreadsheet is a versatile application developed as part
of the GNOME Office project.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /  Vulnerable  /                  Unaffected
    -------------------------------------------------------------------
  1  app-office/gnumeric       < 1.8.1                        >= 1.8.1

Description
===========

Multiple integer overflow and signedness errors have been reported in
the excel_read_HLINK() function in file plugins/excel/ms-excel-read.c
when processing XLS HLINK opcodes.

Impact
======

A remote attacker could entice a user to open a specially crafted XLS
file, possibly resulting in the remote execution of arbitrary code with
the privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gnumeric users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-office/gnumeric-1.8.1"

References
==========

  [ 1 ] CVE-2008-0668
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0668

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200802-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHsgQouhJ+ozIKI5gRAg9aAJ9XP9GNt6gPUMoISL4pIdPERVpRaQCgiXSY
a4mLN2E5WF1e9kEKKcUOWpQ=
=ye33
-----END PGP SIGNATURE-----