[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ GLSA 200802-07 ] Pulseaudio: Privilege escalation



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200802-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Pulseaudio: Privilege escalation
      Date: February 13, 2008
      Bugs: #207214
        ID: 200802-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in pulseaudio may allow a local user to execute actions
with escalated privileges.

Background
==========

Pulseaudio is a networked sound server with an advanced plugin system.

Affected packages
=================

    -------------------------------------------------------------------
     Package                 /  Vulnerable  /               Unaffected
    -------------------------------------------------------------------
  1  media-sound/pulseaudio       < 0.9.9                     >= 0.9.9

Description
===========

Marcus Meissner from SUSE reported that the pa_drop_root() function
does not properly check the return value of the system calls setuid(),
seteuid(), setresuid() and setreuid() when dropping its privileges.

Impact
======

A local attacker could cause a resource exhaustion to make the system
calls fail, which would cause Pulseaudio to run as root. The attacker
could then perform actions with root privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Pulseaudio users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-sound/pulseaudio-0.9.9"

References
==========

  [ 1 ] CVE-2008-0008
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0008

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200802-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHs3VAuhJ+ozIKI5gRArmoAJ9SCqxjbnAssnUt34QI8HtpLXzg8QCfQ1tl
25xRVcl7FL2lc0RTu8mGqgo=
=cDWF
-----END PGP SIGNATURE-----