[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ MDVSA-2008:064 ] - Updated tomboy packages fix improper LD_LIBRARY_PATH handling



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________
 
 Mandriva Linux Security Advisory                         MDVSA-2008:064
 http://www.mandriva.com/security/
 _______________________________________________________________________
 
 Package : tomboy
 Date    : March 7, 2008
 Affected: 2007.1, 2008.0
 _______________________________________________________________________
 
 Problem Description:
 
 A flaw in how tomboy handles LD_LIBRARY_PATH was discovered where by
 appending paths to LD_LIBRARY_PATH the program would also search the
 current directory for shared libraries.  In directories containing
 network data, those libraries could be injected into the application.
 
 The updated packages have been patched to correct this issue.
 _______________________________________________________________________

 References:
 
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4790
 _______________________________________________________________________
 
 Updated Packages:
 
 Mandriva Linux 2007.1:
 e4fec795476776d6cdeb2b875dde8c17  2007.1/i586/tomboy-0.6.1-3.1mdv2007.1.i586.rpm 
 b3f45b1dfc59d49c770529b1d2458c61  2007.1/SRPMS/tomboy-0.6.1-3.1mdv2007.1.src.rpm

 Mandriva Linux 2007.1/X86_64:
 a73e1c14a26e577b6306b70ff2084e74  2007.1/x86_64/tomboy-0.6.1-3.1mdv2007.1.x86_64.rpm 
 b3f45b1dfc59d49c770529b1d2458c61  2007.1/SRPMS/tomboy-0.6.1-3.1mdv2007.1.src.rpm

 Mandriva Linux 2008.0:
 e200a429f743429bfd741ce9f8c71152  2008.0/i586/tomboy-0.8.0-1.1mdv2008.0.i586.rpm 
 54b18c82a1f0037a94c394a0203cb3bc  2008.0/SRPMS/tomboy-0.8.0-1.1mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 6698979ccf4f777c5111794f63a82604  2008.0/x86_64/tomboy-0.8.0-1.1mdv2008.0.x86_64.rpm 
 54b18c82a1f0037a94c394a0203cb3bc  2008.0/SRPMS/tomboy-0.8.0-1.1mdv2008.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (GNU/Linux)

iD8DBQFH0YOhmqjQ0CJFipgRAgSmAJ9otgdVwjfflVe6jpml6bwdnSEqRQCg47aY
Q2rEjKTOGDGKOt2GK6QFVE4=
=2bbj
-----END PGP SIGNATURE-----