[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ GLSA 200803-19 ] Apache: Multiple vulnerabilities



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200803-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Apache: Multiple vulnerabilities
      Date: March 11, 2008
      Bugs: #201163, #204410, #205195, #209899
        ID: 200803-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Apache.

Background
==========

The Apache HTTP server is one of the most popular web servers on the
Internet.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-servers/apache       < 2.2.8                         >= 2.2.8

Description
===========

Adrian Pastor and Amir Azam (ProCheckUp) reported that the HTTP Method
specifier header is not properly sanitized when the HTTP return code is
"413 Request Entity too large" (CVE-2007-6203). The mod_proxy_balancer
module does not properly check the balancer name before using it
(CVE-2007-6422). The mod_proxy_ftp does not define a charset in its
answers (CVE-2008-0005). Stefano Di Paola (Minded Security) reported
that filenames are not properly sanitized within the mod_negociation
module (CVE-2008-0455, CVE-2008-0456).

Impact
======

A remote attacker could entice a user to visit a malicious URL or send
specially crafted HTTP requests (i.e using Adobe Flash) to perform
Cross-Site Scripting and HTTP response splitting attacks, or conduct a
Denial of Service attack on the vulnerable web server.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Apache users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-servers/apache-2.2.8"

References
==========

  [ 1 ] CVE-2007-6203
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6203
  [ 2 ] CVE-2007-6422
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6422
  [ 3 ] CVE-2008-0005
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0005
  [ 4 ] CVE-2008-0455
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0455
  [ 5 ] CVE-2008-0456
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0456

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200803-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFH1wnxuhJ+ozIKI5gRAjqTAJ4zeAHvPbQ2UWBwcVCSxEOV+qOATgCdFdD6
YlRviYEMv15dkIMA5mCW9/Q=
=f/5N
-----END PGP SIGNATURE-----