[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ GLSA 200803-24 ] PCRE: Buffer overflow



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                        GLSA 200803-24:02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PCRE: Buffer overflow
      Date: March 17, 2008
   Updated: March 17, 2008
      Bugs: #209067, #209293
        ID: 200803-24:02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow vulnerability has been discovered in PCRE, allowing
for the execution of arbitrary code and Denial of Service.

Background
==========

PCRE is a Perl-compatible regular expression library. GLib includes a
copy of PCRE.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libpcre      < 7.6-r1                          >= 7.6-r1
  2  dev-libs/glib         < 2.14.6                          >= 2.14.6
                                                              < 2.14.0
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

PCRE contains a buffer overflow vulnerability when processing a
character class containing a very large number of characters with
codepoints greater than 255.

Impact
======

A remote attacker could exploit this vulnerability by sending a
specially crafted regular expression to an application making use of
the PCRE library, which could possibly lead to the execution of
arbitrary code or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PCRE users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-7.6-r1"

All GLib users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.14.6"

References
==========

  [ 1 ] CVE-2008-0674
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0674

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200803-24.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQFH3w2UD/IBIJzjypERAkEBAJ90l88QfhQbz2cSxhOZsZNRmXHjDwCfT4tA
zJ4fapDOrpd8dukYZkMl/fM=
=D3Hn
-----END PGP SIGNATURE-----