[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

29o3 CMS (LibDir) Multiple Remote File Inclusion Vulnerability



Description:

Some vulnerabilities have been discovered in 2903 CMS, which can be exploited by malicious people to compromise a vulnerable system.

Input passed to the "CONFIG[LibDir]" parameter in multiple files is not properly verified before being used to include files. This can be exploited to execute arbitrary PHP code by including files from local or external resources.

Affected scripts:
- /path/lib/page/pageDescriptionObject.php
- /path/lib/layout/layoutHeaderFuncs.php
- /path/lib/layout/layoutManager.php
- /path/lib/layout/layoutParser.php

The vulnerabilities are confirmed in version: 29o3 0.1 Codename Broend PREBETA

Solution:
Edit the source code to ensure that input is properly verified.