[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SQL injection vulnerability in ImpressPages CMS



Vulnerability ID: HTB22386
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_impresspages_cms_2.html
Product: ImpressPages CMS
Vendor: Apro Media
Vulnerable Version: 1.0.4 and Probably Prior Versions
Vendor Notification: 12 May 2010 
Vulnerability Type: SQL Injection
Status: Fixed by Vendor
Risk level: Low 
Credit: High-Tech Bridge SA (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/admin.php" script to properly sanitize user-supplied input in "road[]" variable. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

Attacker can use browser to exploit this vulnerability. The following PoC is available: 


http://host/admin.php?module_id=355&road[]=386%27+union+select+1,user%28%29,3,4,5,6+--+&sort_field[1]=verified&sort_dir[1]=asc&security_token=$valid_token&page[1]=1&page_size[1]=1000


Solution: Upgrade to the most recent version