[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

XSS in SweetRice CMS



Vulnerability ID: HTB22668
Reference: http://www.htbridge.ch/advisory/xss_in_sweetrice_cms.html
Product: SweetRice CMS
Vendor: basic-cms.org ( http://www.basic-cms.org/ ) 
Vulnerable Version: 0.6.7
Vendor Notification: 21 October 2010 
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Low 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/as/index.php" scripts to properly sanitize user-supplied input in username variable from cookie. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

The following PoC is available:


GET /as/index.php HTTP/1.1
Cookie: top_height=')%3B"><script>alert('XSS')%3B</script>;


Solution: Upgrade to the most recent version