[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22833: Information Disclosure in Arctic Fox CMS



Vulnerability ID: HTB22833
Reference: http://www.htbridge.ch/advisory/information_disclosure_in_arctic_fox_cms.html
Product: Arctic Fox CMS
Vendor: Michael Armbruster ( http://sourceforge.net/projects/arcticfox/ ) 
Vulnerable Version: 0.9.4 and probably prior versions
Vendor Notification: 01 February 2011 
Vulnerability Type: Information Disclosure
Risk level: Low 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "acp/includes/nav.inc.php", "acp/includes/edit.inc.php" script, it's possible to generate an error that will reveal MySQL connecttion settings, like user and host.

The following PoC is available:

http://host/acp/includes/nav.inc.php
http://host/acp/includes/edit.inc.php