[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22843: Path disclosure in GD Star Rating wordpress plugin



Vulnerability ID: HTB22843
Reference: http://www.htbridge.ch/advisory/path_disclosure_in_gd_star_rating_wordpress_plugin.html
Product: GD Star Rating wordpress plugin
Vendor: Milan Petrovic  ( http://www.gdstarrating.com/ ) 
Vulnerable Version: 1.9.7
Vendor Notification: 08 February 2011 
Vulnerability Type: Path disclosure
Status: Awaiting Vendor Solution
Risk level: Low 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/wp-content/plugins/gd-star-rating/widgets/widget_top.php" script, it's possible to generate an error that will reveal the full path of the script.
A remote user can determine the full path to the web root directory and other potentially sensitive information.

The following PoC is available:


http://[host]/wp-content/plugins/gd-star-rating/widgets/widget_top.php