[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

DataDynamics Report Library CoreHandler XSS



Class	Input Validation Error
CVE	
Remote	Yes
Local	No
Published	Mar 30 2011 11:00AM
	
Credit	Dionach
Vulnerable	Grapecity DataDynamics Report Library 1.6.1871.61 and earlier

Grapecity's DataDynamics Report Library is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions 1.6.1871.61 and earlier of the DataDynamics.Reports.Web class library are known to be vulnerable. Other versions may also be vulnerable. The vulnerability lies in unsafe calls to the CoreViewerInit.js and CoreController.js scripts when embedded in an ASP.NET handler such as the following:

<% @ WebHandler language="C#" class="DataDynamics.Reports.Web.CoreHandler, DataDynamics.Reports.Web, Version=1.6.1871.61, Culture=neutral, PublicKeyToken=d557f2f30a260da2" codebehind="CoreHandler.cs" %>

To exploit this issue, an attacker must entice an unsuspecting victim into following a malicious URI, such as the following:

http://localhost/CoreHandler.ashx?dd:script=CoreViewerInit.js&reportName=<script>alert('XSS1!')</script>&uniqueId=<script>alert('XSS2!')</script>#
http://localhost/CoreHandler.ashx?dd:script=CoreController.js&uniqueId=<script>alert('XSS1!')</script>&traceLevel=<script>alert('XSS2!')</script>#

Grapecity report that version 1.6.2084.14 is not vulnerable. This is available from the following URL:

http://www.gcpowertools.com/DownloadLatestVersion