[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22930: Multiple XSS in WebCalendar



Vulnerability ID: HTB22930
Reference: http://www.htbridge.ch/advisory/xss_in_webcalendar.html
Product: WebCalendar
Vendor: k5n.us ( http://www.k5n.us/ ) 
Vulnerable Version: 1.2.3
Vendor Notification: 29 March 2011 
Vulnerability Type: XSS (Cross Site Scripting)
Risk level: Medium 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "login.php" script to properly sanitize user-supplied input.
User can execute arbitrary JavaScript code within the vulnerable application.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

[code]
http://[host]/login.php?last_login=123%22%3E%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E
[/code]

The vulnerability exists due to failure in the "colors.php" script to properly sanitize user-supplied input.

[code]
http://[host]/colors.php?color=";><%73cript>alert(document.cookie);</%73cript>
[/code]