[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

LifeSize Room Vulnerabilities



Discovered: 07-13-11
By: Spencer McIntyre (zeroSteiner) SecureState R&D Team
www.securestate.com


Background:
-----------
Multiple vulnerabilities within the LifeSize Room appliance.


Vulnerability Summaries:
------------------------
Login page can be bypassed, granting administrative access to the web interface.
Unauthenticated OS command injection is possible through the web interface.
The easiest way to perform these attacks is using a web proxy.


Vulnerable Versions:
--------------------
Tested on LifeSize Room versions 3.5.3 and 4.7.18, others may be vulnerable.


Authentication By Pass:
-----------------------
Following the request to /gateway.php that references the LSRoom_Remoting.authenticate
function, modify the AMF data in the response from the server to change "false" to "true"
Example:
Original False AMF: "\x0d\x0a\x0d\x0a\x00\x00\x00\x00\x00\x01\x00\x0c\x2f\x35\x37\x2f\x6f\x6e\x52\x65\x73\x75\x6c\x74\x00\x04\x6e\x75\x6c\x6c\x00\x00\x00\x02\x01\x00"
Modified True AMF:  "\x0d\x0a\x0d\x0a\x00\x00\x00\x00\x00\x01\x00\x0c\x2f\x35\x37\x2f\x6f\x6e\x52\x65\x73\x75\x6c\x74\x00\x04\x6e\x75\x6c\x6c\xff\xff\xff\xff\x01\x01"


Command Injection:
------------------
The request to /gateway.php references a vulnerable function LSRoom_Remoting.doCommand
within the encoded AMF data.  The original parameter for the vulnerable function is
"pref -l /var/system/upgrade/status"  Replace this part with the command to be executed.
Authentication to the web application is not necessary however a valid PHP session ID
must be passed within the request.


References:
-----------
CVE-2011-2762 - authentication bypass
CVE-2011-2763 - OS command injection