[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Wordpress advanced-text-widget Plugin Vulnerabilities



On Mon, Nov 21, 2011 at 06:24:14AM +0000, Amir@xxxxxxxx wrote:
> # Wordpress advanced-text-widget Plugin Cross-Site Scripting Vulnerabilities                                        #
> #                                                                                                                   #
> # Download......: http://wordpress.org/extend/plugins/advanced-text-widget/                                         #
> #                                                                                                                   #
> # Bug Found.....: IrIsT?                                                                                            #
> #                                                                                                                   #
> # discovery.....: Am!r (IrIsT?)                                                                                     #
> #                                                                                                                   #
> # contact.......: Amir[at]IrIsT.ir                                                                                  #
> #                                                                                                                   #
> # Exploit.......: http://www.site.com/[path]/wp-content/plugins/advanced-text-widget/advancedtext.php?page=[xss]    #

Do you have a working PoC for this issue? In which version did you test this? I only get error-message:

mod_fcgid: stderr: PHP Fatal error:  Call to undefined function plugin_basename() in <snip>/wp-content/plugins/advanced-text-widget/advancedtext.php on line 11

- Henri Salo