[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ MDVSA-2012:107 ] exif



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2012:107
 http://www.mandriva.com/security/
 _______________________________________________________________________

 Package : exif
 Date    : July 13, 2012
 Affected: 2011., Enterprise Server 5.0
 _______________________________________________________________________

 Problem Description:

 A vulnerability has been discovered and corrected in exif:
 
 An integer overflow in the function jpeg_data_load_data in the exif
 program could cause a data read beyond the end of a buffer, causing
 an application crash or leakage of potentially sensitive information
 when parsing a crafted JPEG file (CVE-2012-2845).
 
 The updated packages have been upgraded to the 0.6.21 version which
 is not vulnerable to this issue.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2845
 http://sourceforge.net/mailarchive/message.php?msg_id=29534027
 _______________________________________________________________________

 Updated Packages:

 Mandriva Linux 2011:
 e95db8e686df9b5423c50372b1ede214  2011/i586/exif-0.6.21-0.1-mdv2011.0.i586.rpm 
 36d045bef55e838adffeb7ab440c1ab6  2011/SRPMS/exif-0.6.21-0.1.src.rpm

 Mandriva Linux 2011/X86_64:
 8fa43ab4492ccdd24a5747f20c3b9bca  2011/x86_64/exif-0.6.21-0.1-mdv2011.0.x86_64.rpm 
 36d045bef55e838adffeb7ab440c1ab6  2011/SRPMS/exif-0.6.21-0.1.src.rpm

 Mandriva Enterprise Server 5:
 150eb2c08f8611278553a3e6a7ca3854  mes5/i586/exif-0.6.21-0.1mdvmes5.2.i586.rpm 
 a006ed9018b5714df575bd155ecd3491  mes5/SRPMS/exif-0.6.21-0.1mdvmes5.2.src.rpm

 Mandriva Enterprise Server 5/X86_64:
 34451413271f02026f76aa593943e559  mes5/x86_64/exif-0.6.21-0.1mdvmes5.2.x86_64.rpm 
 a006ed9018b5714df575bd155ecd3491  mes5/SRPMS/exif-0.6.21-0.1mdvmes5.2.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFP//EEmqjQ0CJFipgRAoxWAJ9bTXYx7pyNTkRQ+FKcYE5wfz6JlwCgxV+D
SN3EYsbVxdixUjURrury7tQ=
=+WbY
-----END PGP SIGNATURE-----