[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

FD - Cobbler Arbitrary File Read CVE-2014-3225



Vulnerability title: Arbitrary file read 

CVE: CVE-2014-3225

Vendor: Cobbler

Product: Cobbler

Affected version: <=2.6.0

Fixed version: N/A

Reported by: Dolev Farhi




----------------------------
VULNERABILITY Details:
----------------------------
In all Cobbler versions (<= 2.6.0) an arbitrary system files read
vulnerability is possible via the cobbler profile creation page.
Cobbler does not validate the file is a .ks file nor does it restrict the
user to a certain path.
Cobbler runs under the root user privileges, which allows read access to all
system files.
This issue exposes all files to any attacker attempting to provide full file
path to crucial system files such as /etc/passwd or /etc/shadow in the
Kickstart path.
https://github.com/cobbler/cobbler/issues/939



--------------------
Proof of concept
--------------------
Create a regular cobbler profile, assign a distribution to it.
In kickstart value, provide /etc/shadow or any other file.
Save -> navigate to "View kickstart" -> file is shown.

------------------------------
PROOF OF CONCEPT vid
------------------------------
https://www.youtube.com/watch?v=vuBaoQUFEYQ