[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVE-2014-4326 Remote command execution in Logstash zabbix and nagios_nsca outputs.

Vendor: Elasticsearch
Product: Logstash
CVE: CVE-2014-4326
Affected versions: Logstash 1.0.14 through 1.4.1

Recommendations: All affected users should upgrade to Logstash 1.4.2.
We also provide patch instructions for Logstash 1.3.x at the bottom of
this note.

The vulnerability impacts deployments that use either the zabbix or
the nagios_nsca outputs. In these cases, an attacker with an ability
to send crafted events to any source of data for Logstash could
execute operating system commands with the permissions of the Logstash

Deployments that do not use the zabbix or the nagios_nsca outputs are
not vulnerable and do not need to upgrade for this reason.

We would like to thank Jan Karwowski and Danila Borisiuk for reporting
the issue and working with us on the resolution.

Related links:


Logstash 1.3.x patch instructions:

   mkdir -p /tmp/logstash-patch/logstash/
   wget -O /tmp/logstash-patch/logstash/outputs/zabbix.rb
   wget -O /tmp/logstash-patch/logstash/outputs/nagios_nsca.rb
   jar uf logstash-1.3.3-flatjar.jar -C /tmp/logstash-patch/
logstash/outputs/zabbix.rb -C /tmp/logstash-patch/

SHA256 of the two files fetched for this patch process: