[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ MDVSA-2014:195 ] libvirt



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2014:195
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : libvirt
 Date    : October 3, 2014
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 Multiple vulnerabilities has been discovered and corrected in libvirt:
 
 An out-of-bounds read flaw was found in the way libvirt's
 qemuDomainGetBlockIoTune() function looked up the disk index in
 a non-persistent (live) disk configuration while a persistent disk
 configuration was being indexed. A remote attacker able to establish a
 read-only connection to libvirtd could use this flaw to crash libvirtd
 or, potentially, leak memory from the libvirtd process (CVE-2014-3633).
 
 A denial of service flaw was found in the way libvirt's
 virConnectListAllDomains() function computed the number of used
 domains. A remote attacker able to establish a read-only connection
 to libvirtd could use this flaw to make any domain operations within
 libvirt unresponsive (CVE-2014-3657).
 
 The updated libvirt packages have been upgraded to the 1.1.3.6 version
 and patched to resolve these security flaws.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3633
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3657
 https://rhn.redhat.com/errata/RHSA-2014-1352.html
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 f3712776775e72816f595c0871bc0b66  mbs1/x86_64/lib64virt0-1.1.3.6-1.1.mbs1.x86_64.rpm
 6d9e776bec340b943fa34c61e6e5d86f  mbs1/x86_64/lib64virt-devel-1.1.3.6-1.1.mbs1.x86_64.rpm
 b5598b223a85629378a719e76710d5f2  mbs1/x86_64/libvirt-utils-1.1.3.6-1.1.mbs1.x86_64.rpm
 cf81559c08aec9aa9f30c56c4e8e4900  mbs1/x86_64/python-libvirt-1.1.3.6-1.1.mbs1.x86_64.rpm 
 858837fd9fcba6e06c7ea16a9d40df1f  mbs1/SRPMS/libvirt-1.1.3.6-1.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFULlzfmqjQ0CJFipgRAvRHAKDi6ayGiIBsBW2s7THqiXuM4thUOwCfeh/S
o5qRhaedDNtKVfEfU+BhESk=
=S7TE
-----END PGP SIGNATURE-----