[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Elasticsearch vulnerability CVE-2015-1427



Summary:
Elasticsearch versions 1.3.0-1.3.7 and 1.4.0-1.4.2 have vulnerabilities in the Groovy scripting engine.  The vulnerabilities allow an attacker to construct Groovy scripts that escape the sandbox and execute shell commands as the user running the Elasticsearch Java VM.  

We have been assigned CVE-2015-1427 for this.


Fixed versions:
Versions 1.3.8 and 1.4.3 disable sandboxing for Groovy by default.  As a consequence, dynamic script execution is disabled for Groovy.


Remediation:
Users should upgrade to 1.3.8 or 1.4.3.  Users that do not want to upgrade can address the vulnerabilities by setting script.groovy.sandbox.enabled to false in elasticseach.yml and restarting the node.

Also, we have published a procedure for moving trusted Groovy dynamic scripts to disk so that users can continue their use, even with Groovy dynamic scripting disabled.  This will require a small client change from the user.


Credit:
We received two reports of similar issues, one from the Cisco Systems Information Security Team and one from Cameron Morris.


CVSS:
Overall CVSS score: 5.8