[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ MDVSA-2015:077 ] python-numpy



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2015:077
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : python-numpy
 Date    : March 27, 2015
 Affected: Business Server 2.0
 _______________________________________________________________________

 Problem Description:

 Updated python-numpy packages fix security vulnerabilities:
 
 f2py insecurely used a temporary file. A local attacker could use this
 flaw to perform a symbolic link attack to modify an arbitrary file
 accessible to the user running f2py (CVE-2014-1858, CVE-2014-1859).
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-1858
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-1859
 http://advisories.mageia.org/MGASA-2014-0089.html
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 2/X86_64:
 b263b7e787b22bdcd742b33c8955f364  mbs2/x86_64/python3-numpy-1.8.0-1.1.mbs2.x86_64.rpm
 7157c0c9db9435121b784a6d1d78b6d0  mbs2/x86_64/python3-numpy-devel-1.8.0-1.1.mbs2.x86_64.rpm
 2c8b2227f573844df99543e7bcb46107  mbs2/x86_64/python-numpy-1.8.0-1.1.mbs2.x86_64.rpm
 3162e4fa35bb17378ce3e373a81db035  mbs2/x86_64/python-numpy-devel-1.8.0-1.1.mbs2.x86_64.rpm 
 650dd731f7edfcae89fcc8e45ccf4993  mbs2/SRPMS/python-numpy-1.8.0-1.1.mbs2.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFVFZENmqjQ0CJFipgRAiqfAKDshMjOCS6jOvsnLDxzalMgK8CSdwCdHled
sKz45XSD3pC1xBUS45LMrSc=
=bep1
-----END PGP SIGNATURE-----