[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ MDVSA-2015:213 ] lftp



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2015:213
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : lftp
 Date    : April 29, 2015
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 Updated lftp packages fix security vulnerability:
 
 lftp incorrectly validates wildcard SSL certificates containing literal
 IP addresses, so under certain conditions, it would allow and use a
 wildcard match specified in the CN field, allowing a malicious server
 to participate in a MITM attack or just fool users into believing
 that it is a legitimate site (CVE-2014-0139).
 
 lftp was affected by this issue as it uses code from cURL for checking
 SSL certificates.  The curl package was fixed in MDVSA-2015:098.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0139
 http://advisories.mageia.org/MGASA-2015-0165.html
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 fb83027b8e1aac5395496e0e3c223c8f  mbs1/x86_64/lftp-4.3.5-2.1.mbs1.x86_64.rpm
 32c3464cda84c65572c8ffcbb757d058  mbs1/x86_64/lib64lftp0-4.3.5-2.1.mbs1.x86_64.rpm
 08e8fd1c3ecd28987cc3e9e26d2cf774  mbs1/x86_64/lib64lftp-devel-4.3.5-2.1.mbs1.x86_64.rpm 
 4f1b3b6cb9abca1c97dcd1978bcf3cdd  mbs1/SRPMS/lftp-4.3.5-2.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFVQNjymqjQ0CJFipgRAgVgAJ9qlzVeZnCRmFz8tRSMdcQVodZ3egCfWt0g
fEApX/Zt09cVgxdL5DkeT7A=
=oreB
-----END PGP SIGNATURE-----