[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CollabNet Subversion Edge autocomplete on



# Vuln Title: The CollabNet Subversion Edge management frontend login page
# password field has autocomplete enabled
#
# Date: 28.06.2015
# Author: otr
# Software Link: https://www.open.collab.net/downloads/svnedge
# Vendor: CollabNet
# Version: 4.0.11
# Tested on: Fedora Linux
# Type: Lack of defensive measures
#
# Risk: Low
# Status: public/fixed
# Fixed version: 5.0
# https://ctf.open.collab.net/sf/wiki/do/viewPage/projects.svnedge/wiki/Release_5.0.0

Timeline:

2014-10-09 Flaw Discovered
2014-10-20 Vendor contacted
2014-10-21 Vendor response
2014-12-08 Vendor fix proposal
2014-12-08 Extension of embargo to 19.4.2015
2015-05-04 Extension of embargo until release of version 5.0
2015-05-18 Release of version 5.0 and public disclosure

Summary:

The CollabNet Subversion Edge management frontend login page password field has
autocomplete enabled. This may allow an attacker to retrieve a stored password
from the browsers key store.

Fix proposal:

Set the autocomplete=off attribute for password fields. Provide an option in the
configuration file to configure this feature.

Vendor fix:

There is now a boolean flag in <data>/conf/security.properties which allow these
organizations to activate autocomplete="off".