[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Logstash vulnerability CVE-2015-5619
Logstash 1.5.3 and prior versions are vulnerable to a SSL/TLS security
issue which allows an attacker to successfully implement a man in the
middle attack. This vulnerability is not present in the initial
installation of Logstash. This insecurity is exposed when users
configure Lumberjack output to connect two Logstash instances. In such
deployments, a Logstash instance is used to collect logs from a
webserver and securely transmit them to a central Logstash instance to
perform additional filtering and storing.
Note: Communication between Logstash Forwarder and Lumberjack Input in
Logstash is not affected by this vulnerability.
We have been assigned CVE-2015-5619 for this issue.
Version 1.5.4 and 1.4.5 has been patched with a fix that addresses
Users that currently use Logstash with the Lumberjack output or may
want to use it in the future should upgrade to 1.5.4 or 1.4.5.
Users that do not want to upgrade can address the vulnerability by
disabling the Lumberjack output.
Markus Frosch reported this issue.
Overall CVSS score: 4.3