[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Subject mail: CVE-2015-7320 - Multiple Reflective XSS in Appointment Booking Calendar 1.1.7 WordPress plugin



Vulnerability title: Multiple Reflective XSS in Appointment Booking Calendar 1.1.7 WordPress plugin
CVE: CVE-2015-7320
Vendor: WordPress DWBooster
Product: Appointment Booking Calendar
Affected version: 1.1.7
Fixed version: 1.1.8
Reported by: Ibéria Medeiros

Vulnerability Details:
=====================
It was discovered that no protection against multiple reflective XSS attacks was implemented, resulting in an attacker being able to retrive user data from end user, such as session cookies.

The Appointment Booking Calendar 1.1.7 WordPress plugin is vulnerable to 3 reflective XSS vulnerabilities.
Three XSS vectors were identified in cpabc_appointments_admin_int_bookings_list.inc.php

System affected:
===============
Any system that access to a web site developed by WordPress CMS version 4.3.1 or higher and uses the Appointment Booking Calendar plugin v.1.1.7 or early.

Solution:
========
Update to Appointment Booking Calendar 1.1.8 plugin

Disclosure Timeline:
===================
Vendor Notification: September 22, 2015
Vendor fixed vulnerability: September 22, 2015
Public Disclosure: September 26, 2015