[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Multiple Reflected XSS in Payment Form for PayPal Pro version 1.0.1 WordPress plugin



Vulnerability title: Multiple Reflected XSS in Payment Form for PayPal Pro version 1.0.1 WordPress plugin
CVE: CVE-2015-7666
Vendor: WordPress DWBooster
Product: Payment Form for PayPal Pro
Affected version: 1.0.1
Fixed version: 1.0.2
Reported by: Ibéria Medeiros

Vulnerability Details:
=====================
It was discovered that no protection against multiple reflected XSS attacks was implemented, resulting in an attacker being able to retrive user data from end user, such as session cookies.

The Payment Form for PayPal Pro version 1.0.1 WordPress plugin is vulnerable to 2 reflected XSS vulnerabilities.
The cp_ppp_admin_int_message_list.inc.php file is vulnerable to XSS attacks via $_GET[\"cal\"] parameter.

System affected:
===============
Any system that access to a web site developed by WordPress CMS version 4.3.1 or earlier and uses the Payment Form for PayPal Pro version 1.0.1.

Advisory:
========
https://wordpress.org/plugins/payment-form-for-paypal-pro/changelog/

Solution:
========
Update to Payment Form for PayPal Pro version 1.0.2 plugin.
https://wordpress.org/plugins/payment-form-for-paypal-pro/

Disclosure Timeline:
===================
Vendor notification: September 26, 2015
Vendor fixed vulnerability: September 27, 2015
Public advisory: September 27, 2015
Public disclosure: October 4, 2015