[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[CVE-2015-7670] Multiple SQL Injection in Support Ticket System 1.2 WordPress plugin



Vulnerability title: SQL Injection in Support Ticket System 1.2 WordPress plugin
CVE: CVE-2015-7670
Vendor: Tim Dahlmanns
Product: Support Ticket System
Affected version: 1.2
Fixed version: 1.2.1
Reported by: Ibéria Medeiros

Vulnerability Details:
=====================
It was discovered that no protection against SQL injection attack was implemented, resulting in an attacker being able to retrieve users and ticket data from database; and insert data about users and tickets in the database; then using these data in future attacks.

The Support Ticket System 1.2 WordPress plugin is vulnerable to 5 SQLI injection (SQLI) vulnerabilities.
The includes/update.php file is vulnerable to SQLI attacks via $user and $id parameters.

System affected:
===============
Any system that access to a web site developed by WordPress CMS version 4.3.1 or earier and uses the Support Ticket System v.1.2 or early.

Advisory:
========
https://wordpress.org/plugins/simple-support-ticket-system/changelog/

Solution:
========
Update to Support Ticket System v.1.2.1 plugin
https://wordpress.org/plugins/simple-support-ticket-system/

Disclosure Timeline:
===================
Vendor notification: September 29, 2015
Vendor fixed vulnerability: October 6, 2015
Public advisory: October 6, 2015
Public disclosure: October 6, 2015