[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Remote Code Execution in Shopware <5.1.5 (CVE-2016-3109)



CREDITS
========
This issue has been identified by David Vieira-Kurz of Immobilien Scout GmbH.

CVE
====
CVE-2016-3109

AFFECTED PRODUCT
==================
Shopware < 5.1.5 : https://en.shopware.com/

IMPACT
=======
This issue has been triaged with the highest severity (CRITICAL) by the Shopware maintainer because it allows unauthenticated remote code execution by any attacker! This means that an attacker is able to read ANY files on the target system, create new files with malicious content and run arbitrary code on the target system.

PROOF OF CONCEPT
==================
The script located at "/backend/Login/load/" is prone to remote code execution. A proof of concept has been sent to the maintainer and verified by the maintainer of Shopware. 
For the time being we will not provide any exploit code publicly.

HOTFIX
======
 https://github.com/shopware/shopware/commit/d73e9031a5b2ab6e918eb86d1e2b2e873cd3558d

TIMELINE
========
05/Apr/2016: issue has been identified
05/Apr/2016: issue has been sent to the maintainer
06/Apr/2016: maintainer has verified the issue
07/Apr/2016: maintainer sent hotfix for review
11/Apr/2016:  maintainer released a hotfix (version 5.1.5)
23/Apr/2016: this advisory has been published