[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[CVE-2016-5728] Double-Fetch Vulnerability in Linux-4.5/drivers/misc/mic/host/mic_virtio.c



I found this double-fetch vulnerability when I was doing my research on double-fetch issue analysis, and I?d like to make an anouncement here. 

This was found in Linux kernel file Linux-4.5/drivers/misc/mic/host/mic_virtio.c, and crafted user space data change under race condition will lead to consequences like over-boundary access on the kernel buffer, information leakage or kernel crash.
================================================================================
1. Affected Versions: Linux Kernel 4.5 and earlier versions.

2. Detailed description: Kernel Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=116651

3. Patch: This has been confirmed by the maintainers and  patched in the new version: https://github.com/torvalds/linux/commit/9bf292bfca94694a721449e3fd752493856710f6

4. CVE: The Common Vulnerabilities and Exposures (CVE) project has assigned the name CVE-2016-5728 to this issue. This is an entry on the CVE list (http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-5728), which standardizes names for security problems.

Kind regards
Pengfei Wang