[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[CVE-2016-6480] Double-Fetch Vulnerability in Linux-4.5/drivers/scsi/aacraid/commctrl.c



I found this double-fetch vulnerability when I was doing my research on double-fetch issue analysis, and I?d like to make an announcement here. 

This was found in Linux kernel file Linux-4.5/drivers/scsi/aacraid/commctrl.c, and crafted user space data change under race condition will lead to over-boundary access in kernel structure or local buffer, and serious consequence might be caused.
==============================================
1. Affected Versions: Linux Kernel 4.5 and earlier versions.

2. Detailed description in my report to Kernel Bugzilla:  https://bugzilla.kernel.org/show_bug.cgi?id=116751

3. CVE: The Common Vulnerabilities and Exposures (CVE) project has assigned the entry CVE-2016-6480 to this issue. 

Even though some maintainers have confirmed this issue on the mailing list, this problem has not yet been patched since my first report three months ago. I hope this could be patched as soon as possible. 

Kind regards
Pengfei Wang