[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [ISSForum] Still cannot enable DB Chainging



Try this:

For SQL Server 2000 SP3 run the following command from SQL Query Analyzer

EXEC sp_dboption 'RealSecureDB', 'db chaining', 'true' 


For MSDE 2000 SP3 run the following command from the command prompt

Osql -E -d RealSecureDB -Q "EXEC sp_dboption 'RealSecureDB', 'db chaining', 'true'

---------------------------------------------------------------
Or you can do this manually directly in the Enterprise Manager
But be cafefull, there's a bug in the OK button

Select Properties of the RealSecureDB database and go to the Options tab
Select Allow cross-datatabase ownership chaining
Deselect and select any other option (this will enable the OK button)

-------------------------------------------------------------
Another option is to enable chaining during the intallation process. I'm
not sure, but I thing you should select custom installation. The problem is that
this will enable chaining for all databases and this is not recomended.



-----Original Message-----
From: Mohr James [mailto:james.mohr@xxxxxxxxx]
Sent: Friday, January 16, 2004 5:47 AM
To: ISSForum@xxxxxxx
Subject: AW: [ISSForum] Still cannot enable DB Chainging


Thanks anyway, but don't bother. My boss was getting extremely impatient. No of the methods works. I also received some private messages with things that I had already tried, but there was no option anywhere to enable db chaining, neither for all databases nor for individual ones.

I ended up implementing the Microsoft-Method of troubleshooting and removed then re-installed MS SQL. This time I installed the Full version and not the desktop version. And this point I am trying to bring the system back up. Thanks for the help. 

Regards,

Jim Mohr

-----Ursprüngliche Nachricht-----
Von: Higgins, David [mailto:David.Higgins@xxxxxxxxxxxxxxx] 
Gesendet: Donnerstag, 15. Januar 2004 15:57
An: Mohr James
Betreff: RE: [ISSForum] Still cannot enable DB Chainging


I can't find how / where we changed it now, but ISS tech support helped us solve this same issue.  It's a setting in a policy file or the registry somewhere.   I can't remember nor find my notes.  I'll do some more digging this afternoon and see if I can find it.

DLHiggins
Security Specialist

_______________________________________________
ISSForum mailing list
ISSForum@xxxxxxx

TO UNSUBSCRIBE OR CHANGE YOUR SUBSCRIPTION, go to https://atla-mm1.iss.net/mailman/listinfo

_______________________________________________
ISSForum mailing list
ISSForum@xxxxxxx

TO UNSUBSCRIBE OR CHANGE YOUR SUBSCRIPTION, go to https://atla-mm1.iss.net/mailman/listinfo