[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [ISSForum] Console Version



 Hi,

Had the same problem ...  Reinstalled the console (with the install file located under /Apache2/ConsoleUpdate) and finally managed to launch it ... However I'm now stuck on another error, when it tries to load groups. It seems like there is a database problem.
Log included :
(...)
The server could not execute this request.
net.iss.rssp.remote.interfaces.ServiceException
    at
net.iss.rssp.gui.ServerController.doConnect(ServerController.java:267)
    at
net.iss.rssp.gui.site.ConnectionManager.connect(ConnectionManager.java:89)
    at net.iss.rssp.gui.ServerController.login(ServerController.java:505)
    at net.iss.rssp.gui.ServerController$5.run(ServerController.java:1107)
    at java.lang.Thread.run(Thread.java:534)

Exception while calling getGroupTree.
net.iss.rssp.security.LocalizedSecurityException
    at
net.iss.rssp.security.server.SecureAdaptorImpl.invoke(SecureAdaptorImpl.java:137)
    at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:261)
    at sun.rmi.transport.Transport$1.run(Transport.java:148)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport.java:144)
    at
sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
    at
sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
    at java.lang.Thread.run(Thread.java:534)

java.lang.IndexOutOfBoundsException: Attempted getObject for invalid column index: 10 (valid range 1 - 9)
    at net.iss.rssp.db.DBResultSet.getObject(DBResultSet.java:113)
    at net.iss.rssp.db.DBResultSet.getInt(DBResultSet.java:135)
    at
net.iss.rssp.server.database.GroupHandler.createGroupFromResultSet(GroupHandler.java:506)
    at
net.iss.rssp.server.database.GroupHandler.handleGroupTreeRow(GroupHandler.java:493)
    at
net.iss.rssp.server.database.GroupHandler.readGroupTree(GroupHandler.java:217)
    at
net.iss.rssp.remote.impl.GroupBrokerImpl.getGroupTree(GroupBrokerImpl.java:503)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at
net.iss.rssp.security.server.SecureAdaptorAction.run(SecureAdaptorAction.java:22)
    at
net.iss.rssp.security.server.SecureAdaptorImpl.invoke(SecureAdaptorImpl.java:114)
    at sun.reflect.GeneratedMethodAccessor17.invoke(Unknown Source)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:261)
    at sun.rmi.transport.Transport$1.run(Transport.java:148)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport.java:144)
    at
sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
    at
sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
    at java.lang.Thread.run(Thread.java:534)

(...)

I also tried to reinstall RSSP Database component, but it screwed my RSSP install and I'm currently reinstalling the whole thing.

Hope it helps (though I'm not sure at all ...)

Emmanuel

-----Message d'origine-----
De : Ennis, Jeff (ISS Virginia) [mailto:jennis@xxxxxxx] 
Envoyé : mardi 29 juin 2004 23:48
À : Ayden Nash; issforum@xxxxxxxxxxxxxxxx
Objet : RE: [ISSForum] Console Version

I believe what you are seeing is the result of connecting to a SiteProtector SP4 Application Server with a console that is based on Service Pack 3.  Install the console that is based on Service Pack 4 and you should be fine.

Hope that helps,

-Jeff

-----Original Message-----
From: issforum-bounces@xxxxxxxxxxxxxxxx On Behalf Of Ayden Nash
Sent: Monday, June 28, 2004 2:20 AM
To: issforum@xxxxxxxxxxxxxxxx
Subject: [ISSForum] Console Version


Hi all,
 
After upgrading a SiteProtector machine to SP4 I receive the following error once I attempt to login;
 
"The client version you are currently using is incompatible with the server to which you are trying to establish a connection.  Your client version could be older or newer than the server.  If it is older, please click Yes when your client asks if you would like to upgrade. Otherwise, install a client version equivalent to the version of your server (if you do not know this information, contact your SiteProtector Administrator)."
 
Is this the result of a bad upgrade? Or is it normal?
 
Thanks,
Ayden
 
 
 
_______________________________________________
ISSForum mailing list
ISSForum@xxxxxxx

TO UNSUBSCRIBE OR CHANGE YOUR SUBSCRIPTION, go to https://atla-mm1.iss.net/mailman/listinfo/issforum

To contact the ISSForum Moderator, send email to mod-issforum@xxxxxxx

The ISSForum mailing list is hosted and managed by Internet Security Systems, 6303 Barfield Road, Atlanta, Georgia, USA 30328.

_______________________________________________
ISSForum mailing list
ISSForum@xxxxxxx

TO UNSUBSCRIBE OR CHANGE YOUR SUBSCRIPTION, go to https://atla-mm1.iss.net/mailman/listinfo/issforum

To contact the ISSForum Moderator, send email to mod-issforum@xxxxxxx

The ISSForum mailing list is hosted and managed by Internet Security Systems, 6303 Barfield Road, Atlanta, Georgia, USA 30328.


_______________________________________________
ISSForum mailing list
ISSForum@xxxxxxx

TO UNSUBSCRIBE OR CHANGE YOUR SUBSCRIPTION, go to https://atla-mm1.iss.net/mailman/listinfo/issforum

To contact the ISSForum Moderator, send email to mod-issforum@xxxxxxx

The ISSForum mailing list is hosted and managed by Internet Security Systems, 6303 Barfield Road, Atlanta, Georgia, USA 30328.