[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AW: [suse-security] Using SSL Certs



I found the entry in apache, not apache2. I also notice that it (SSL) would only try to come up if I restarted apache & not apache2. Also, I had to shut down Apache2 otherwise Apache with SSL wouldn't come up which is very confusing to a newbie! Netstat shows https listening but I can't get a connection with the browser. Any more suggestions? I am sure there is a better way to do this, so please pardon my lack of experience.

Eric

Stefan.Junge@xxxxxxxxxxxxxxx wrote:

Hi Eric,

Have you configuered the file /etc/sysconfig/apache ?
There is a setting to enable SSL: HTTPD_SEC_MOD_SSL=yes.

Greetings

Stefan
-----Ursprüngliche Nachricht-----
Von: Eric Kahklen [mailto:eric@xxxxxxxxxxx] Gesendet: Freitag, 6. Februar 2004 06:48
An: suse-security List
Betreff: [suse-security] Using SSL Certs

I followed the directions from
http://www.eclectica.ca/howto/ssl-cert-howto.php to create and use SSL certificates. I was able to successfully create the certificates for testing but cannot get an ssl connection via my browser to the site. I added the site certificate and private key paths to the httpd.conf like below from the 'how to':
   SSLCertificateFile /home/httpd/ssl/cert.pem
   SSLCertificateKeyFile /home/httpd/ssl/key.pem

This is my first attempt at using SSL with Apache so is there something I am missing? The how to simply says to put these entries in the httpd.conf and restart Apache. mod_ssl is also installed.

Any ideas would be appreciated.

Thanks,

Eric

--
Check the headers for your unsubscription address For additional commands, e-mail: suse-security-help@xxxxxxxx Security-related bug reports go to security@xxxxxxx, not here




--
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here