[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[suse-security] Re: [SLE] Re: [suse-security] How do I activate TLS on sendmail?



On Friday 07 May 2004 06:22, Gordon Cichon wrote:
> Hi John,
>
> thanks for your help. I created the certificates the way you explained
> it. Now, I tried to send email with it. I started saslauthd, and when I
>
> try to send mail, I get the following error:
> > May  7 16:10:32 parsley sendmail[25145]: no secret in database
> > May  7 16:10:32 parsley sendmail[25145]: unable to open Berkeley db
> > /etc/sasldb2: No such file or directory
>
> What does that mean?

You did add the users into the database right?
saslpasswd2 is the command you use for that.


> I also tried to switch the authentification method in
> /etc/sysconfig/saslauthd from "pam" to "shadow". After SuSEconfig and
> restarting all demons, I still get the same error.
>
> What can I do?

I've never gotten anything but sasl to work, 
I'm going to send you some notes off-list that I compiled while
getting this to work.  There was a lot of dinking around to finally
get it up and running because the sasl bits are not well documented
and some authentication methods don't work (at least not for me).

I was able to get this to work with Suse 8.1 and 8.2 even though one
uses sasl and the other sasl2.

I'll send my notes by separate mail.

-- 
_____________________________________
John Andersen

-- 
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here