[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [suse-security] kdelibs patch install problems under 8.1



Hello,

John Whelan wrote:
> The recent SUSE Security Announcement: kdelibs (SuSE-SA:2004:014) has
> only an update for version kdelibs3-3.0.5-54. and not the version
> kdelibs3-3.0.3-68 that was initially installed under SUSE 8.1.
>
> If the current patch update is attempted on SUSE 8.1, the following
> message is displayed:
> error: failed dependencies:
>         libstdc++.so.5(GLIBCPP_3.2.2) is needed by kdelibs3-3.0.5-54
[...]
> I could do an install/upgrade using the nodeps option, however I
> would be fearful that I would break something.
> How can I avoid the above problems and install a fix for kdelibs
> under SUSE 8.1 that has currently kdelibs3-3.0.3-68 installed?

Download the source RPM and compile it:   rpm --rebuild kdelibs*.src.rpm

And please send a bugreport to http://www.suse.de/feedback so that SuSE 
can fix the problem. According to your problem description, it seems 
that they have compiled it with a wrong version of libstdc++ installed.


Gruß

Christian Boltz
-- 
Linux - Life is too short for reboots


--
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here