[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [suse-security] Problems with recent SuSE 8.0 patches



On Fri, 28 May 2004, Armin Schoech wrote:

Hi,

If you use SLES8 and/or SL 8.1: there was a dependecy problem
with kdelibs3, gcc and libstdc++. Thats why updating kdelibs3 fails.
If you update gcc/libstdc++ beforehand, it should work, according
to the kdelibs maintainer. I know thats ugly, but that seems
to be the way for now, if theres anything new, I will let you know.
If there are still any problems, please let me know.

Sebastian

> Hi!
> 
> > >I have a problem with the recent kdelibs3 update on my SuSE 8.0 
> > >servers. The dependency checking gives me the following error message:
> > >
> > >error: failed dependencies:
> > >        kdelibs3 = 3.0.5 is needed by kdelibs3-devel-3.0.5-28
> > >        kdelibs3 >= 3.0.3 is needed by kdebase3-3.0.4-76
> > >
> > This is isn't really a security question, but ... :-)
> > 
> > It appears you're trying to install kdelibs3-devel-3.0.5-28 and 
> > kdebase3-3.0.4-76; if so, that is incorrect.  Note the version numbers 
> > do not match:  3.0.5 versus 3.0.4.  Make sure all your kde rpms come 
> > from the same "version family".
> >
> --> Well, IMHO it is a security question because I can't install a 
> security update provided by SuSE...
> 
> I was wondering myself about the differing versions. But I didn't 
> install any other KDE packages than the originals from the SuSE CDs + 
> all the patches provided by SuSE (which obviously included different 
> versions for different KDE packages). So now I'm still curious how to 
> fix this with the RPMs provided by SuSE?
> 
> Any hints are appreciated!
> 
> Armin
> 
> 

-- 
~
~ perl self.pl
~ $_='print"\$_=\47$_\47;eval"';eval
~ krahmer@xxxxxxx - SuSE Security Team
~


-- 
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here