[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [suse-security] Configuring PHP 4.3.6 on SuSE 9.0 Pro



> I've viewed the previous mail threads on this topic and tried many
> variations.  However, I cant get it to work.  I have verified that my
paths
> are correct for libpng but I still get the same error:
>
> configure: error: libpng.(also) not found
>
> This is what I run:
>
> ./configure --prefix=/www/php --with-apxs2=/www/bin/apxs
> --with-config-file-path=/www/php --enable-sockets
> --with-mysql=/usr/bin/mysql --with-zlib-dir=/usr/share/doc/packages
> --with-gd --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib
>
> TIA
>
> Tom

Hi!

Ok, you want to have 4.3.6, because 4.3.3 is shipped with SuSE 9.0, but if
you want to use it, you have to do some major or minor changes and got to
get all packages (apache, php, mysql) to configure it and recompile it.

What about /srv/www/<path> instead of /www/<path> for data and /www/<path>
for binaries?

Try ./configure --help for help on configureing the sources.

Did you check, if you have all sources you need?
You will need to compile php, phplib, mysql-client, mysql and apache.
Within the packages (.rpm) of SuSE you will need to install the developement
packages to have the headerfiles, that are needed to compile your apache.

Have a closer look at the errormessages, they will tell you what is missing.

I saw somewhere an apachetoolkit, which allows to let the script set all
env. variables and then configures it by itself.
You only have to get the sources and then run the script.
I found it somewhere at sourceforge (www.sf.net) or feshmeat
(freshmeat.net/).

Philippe


-- 
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here