[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [suse-security] liby2util update on SuSE 9.1 breaks online_update?

Hash: SHA1

The Friday 2005-10-07 at 11:06 +0100, Hubertus A. Haniel wrote:

> I have seen this on SuSE 9.1 only - SLES9 and all other SuSE 9.x distros 
> seem to be fine: After applying the recently released liby2util update 
> online_update no longer seems to function:
> online_update -sk all
> online_update: error while loading shared libraries: 
> /usr/lib/liby2pm.so.2: undefined symbol: _ZN6VendorC1ERKSs
> Has anybody else seen this?

If I'm not mistaken, it was documented by Mr. Meissner (although later 
than your post):

| Date: Fri, 07 Oct 2005 14:45:18 +0200
| From: Marcus Meissner <meissner@xxxxxxx>
| Subject: [suse-security-announce] SUSE Security Summary Report SUSE-SR:2005:022

     A problem appeared in the SUSE Linux 9.1 update due to a symbol
     mismatch caused by incompatible changes in SUSE Linux Enterprise
     Server 9 which were not correctly merged back to SUSE Linux 9.1.
     If you are using SUSE Linux 9.1 and can no longer start YaST
     package manager or online_update, please reinstall the liby2util
     RPM from the original CD by hand.

- -- 
       Carlos Robinson

Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Made with pgp4pine 1.76


Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here